Issue on Outbound calls in the UK
Incident Report for Aircall
Resolved
This incident has been resolved.
Posted Aug 15, 2019 - 21:56 CEST
Monitoring
We are seeing signs of recovery and are monitoring the situation.
Posted Aug 15, 2019 - 20:52 CEST
Investigating
We are experiencing an issue on Outbound calls in the UK which can cause delays and call quality issues.
Posted Aug 15, 2019 - 19:13 CEST
This incident affected: Outbound calls.