Aircall Support Portal accessibility
Incident Report for Aircall
Resolved
The Aircall Support Portal is fully stable.
Posted Jul 23, 2024 - 15:18 UTC
Monitoring
Our provider has implemented a fix and is observing improvements.
Posted Jul 23, 2024 - 13:50 UTC
Update
The issues experienced by some users may be the following:
- Access to the page support.aircall.io
- Portal authentication in support.aircall.io
- Chat with the Support team
Posted Jul 23, 2024 - 12:40 UTC
Identified
Some users may not be able to access support.aircall.io due to an ongoing incident impacting our provider.

We will provide an update as soon as we have further details.
Posted Jul 23, 2024 - 12:30 UTC