Unable to Make or Receive Calls
Incident Report for Aircall
Resolved
Following our investigation, we have identified the root cause as the Internet Service Provider of some of our users on the West Coast of the United States. We suggest that you reach out to your ISP or use an alternative network if you are experiencing these symptoms.
Posted Mar 05, 2024 - 21:16 UTC
Investigating
We are currently investigating an issue where some users may not be able to make or receive calls.
Posted Mar 05, 2024 - 20:53 UTC
This incident affected: Aircall Apps, Inbound calls, and Outbound calls.