Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2025 - 05:00 UTC
Scheduled
Aircall has a scheduled maintenance window on Saturday, May 10th starting at 05:00 UTC. During this time, our team will be performing maintenance on our Web database as part of our ongoing commitment to improving the reliability and performance of our platform.
You may experience delays or errors during a brief moment of a few seconds during the maintenance window.
To ensure smooth functionality, we recommend refreshing your Aircall Dashboard or Aircall App after the maintenance is complete.
The maintenance will be carried out with the following schedule: 05:00 – 06:00 UTC 3:00PM – 4:00PM Sydney (AEST) 6:00AM – 7:00AM London (BST) 1:00AM – 2:00AM New York (EST)
Posted May 09, 2025 - 08:49 UTC
This scheduled maintenance affected: Network (Inbound Calls, Outbound Calls), Aircall Apps (Aircall Workspace App, Aircall Desktop App (Legacy), Aircall Mobile App), and Aircall Dashboard (Live Monitoring).