Issues accessing Aircall App and Aircall Dashboard

Incident Report for Aircall

Resolved

The issue affecting the Aircall Apps has been fully resolved. This was a transient issue that impacted our User Interface, promptly fixed by Aircall Engineering.

We appreciate your patience and understanding while we worked to restore normal functionality. If you or your customers continue to experience issues, please don’t hesitate to contact Aircall Support team.
Posted May 14, 2025 - 13:44 UTC

Monitoring

The issue has been identified, and the system seems to have recovered to normal.

We recommend the impacted issues to reload and retry accessing the App/Dashboard.

We continue monitoring it and we will provide further updates as needed.
Posted May 14, 2025 - 13:10 UTC

Investigating

We are currently investigating reports of instability impacting some users.

Our team is actively working to identify the root cause.
We’ll share more updates here as soon as we have additional information.
Posted May 14, 2025 - 13:04 UTC
This incident affected: Aircall Apps (Aircall Workspace App) and Authentication (Login).