Users not able to save Contacts
Incident Report for Aircall
Resolved
This situation is resolved. Users are now able to save Contacts.
Posted Oct 15, 2024 - 07:14 UTC
Investigating
We're investigating reports of Users not being able to save Contacts.
Posted Oct 14, 2024 - 22:02 UTC
This incident affected: Aircall Apps.