Issue on inbound calls
Incident Report for Aircall
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 18:21 UTC
Monitoring
We’re seeing improvements and will keep monitoring.
Posted Apr 28, 2021 - 17:55 UTC
Identified
We have intermittent issues on call connections, the issue is coming from one of our provider, we contacted them, we are working with this provider to fix the situation.
We keep you informed of the resolution progress.
Posted Apr 28, 2021 - 17:28 UTC
Investigating
We are experiencing issues with routing calls. Our team is working closely with this provider to fix the situation.

We will be updating this status page to keep you informed of the resolution progress.
Posted Apr 28, 2021 - 16:41 UTC
This incident affected: Inbound calls.