Aircall Dashboard Analytics Pages Not Loading

Incident Report for Aircall

Resolved

This situation has been resolved.
Posted Mar 27, 2025 - 22:03 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Mar 27, 2025 - 20:37 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 18:34 UTC

Investigating

We are currently investigating an issue where the Aircall Analytics dashboards are not loading any data. Our team is actively working to identify the cause and restore full functionality as soon as possible.
Posted Mar 27, 2025 - 17:40 UTC
This incident affected: Aircall Dashboard (Analytics).