Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 08, 2025 - 03:00 UTC
Scheduled
Aircall has a scheduled maintenance window starting on Saturday, February 8th at 3AM UTC. During this time, our team will be upgrading the data and analytics capabilities of our platform. This enhancement is a key step in our ongoing commitment to improving the reliability and performance of our services.
We do not expect any user impact; however, there may be brief periods of elevated latency when using the Aircall Dashboard, and users may receive a "Something Went Wrong" message when using Live Monitoring. We are making every effort to minimize any disruption.
The maintenance will be carried out with the following schedule: 3:00AM - 5:00AM UTC 2:00PM - 4:00PM Sydney 3:00AM - 05:00AM London 10:00PM - 12:00AM New York (Friday, February 7th)
Posted Feb 06, 2025 - 15:11 UTC
This scheduled maintenance affected: Admin Dashboard.