Calls to Singapore Numbers Are Failing
Incident Report for Aircall
Resolved
The incident has been resolved.
Posted Nov 22, 2023 - 10:37 UTC
Monitoring
A fix has been applied, we are monitoring the results.
Posted Nov 22, 2023 - 09:18 UTC
Investigating
We are investigating a connectivity issue causing inbound calls failures in Singapore.
Posted Nov 22, 2023 - 04:31 UTC
This incident affected: Inbound calls.