Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2025 - 03:00 UTC
Scheduled
Aircall has a scheduled maintenance window on Saturday, May 10th starting at 03:00 UTC. During this time, our team will be performing maintenance on the Live Monitoring database as part of our ongoing commitment to improving the reliability and performance of our platform.
We do not anticipate any user impact. However, you may experience brief delays in data refresh within the Aircall Dashboard during the maintenance window.
To ensure smooth functionality, we recommend refreshing your Dashboard after the maintenance is complete.
The maintenance will be carried out with the following schedule: 03:00 – 05:00 UTC 1:00PM – 3:00PM Sydney (AEST) 4:00AM – 6:00AM London (BST) 11:00PM, Friday, May 9th – 1:00AM New York (EST)
Posted May 05, 2025 - 16:45 UTC
This scheduled maintenance affected: Aircall Dashboard (Live Monitoring).