The issue affecting the Workspace App update has been fully resolved. It impacted a small subset of users during the App update on May 13th. The mitigation was to uninstall and reinstall the Workspace App by downloading it from https://aircall.io/download/. The issue has been resolved with a fix to the Update mechanism, and further updates should be seamless.
We appreciate your patience and understanding while we worked to restore normal functionality. If you or your customers continue to experience issues, please don’t hesitate to contact Aircall Support team.
Posted May 14, 2025 - 15:03 UTC
Update
We are continuing to monitor for any further issues.
Posted May 14, 2025 - 07:22 UTC
Monitoring
The issue should be mitigated. If users continue to experience this issue, please refresh the Aircall Workspace app to ensure the fix takes effect.
Posted May 13, 2025 - 10:25 UTC
Identified
As a mitigation attempt, we disabled noise cancelling for Workspace users. Some of the impacted users may start noticing performance improvements. We continue to investigate and monitor the situation.
Posted May 13, 2025 - 10:01 UTC
Investigating
We are investigating the root cause of high loading times on Aircall Workspace, for a subset of users.
Posted May 13, 2025 - 09:32 UTC
This incident affected: Aircall Apps (Aircall Workspace App).