Issue on inbound and outbound calls between 5:42 and 5:49 UTC
Incident Report for Aircall
Resolved
Today between 5:42 and 5:49 UTC, we faced network connectivity issue. As a result, our service might not have been available during this time lapse.
The situation has reverted to normal.
Posted Apr 01, 2021 - 05:45 UTC