Issue on inbound/outbound calls in NA
Incident Report for Aircall
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 15:56 UTC
Monitoring
One of our carriers was experiencing issues with routing calls in North America. This issue appears to be resolved as of 9:23am EDT, but we are monitoring all retroactive investigations by our carrier.

We will be updating this status page to keep you informed of the resolution progress.
Posted Apr 07, 2021 - 14:37 UTC
This incident affected: Inbound calls and Outbound calls.